Eduard
Forum Replies Created
Just want to give you an update. Activating the WordPress debug.log showed several error messages, one of which was timeout errors for scripts. I did not see anything related to WPDM Pro however.
We have now solved the script timeouts of our theme and as a result, WPDM Pro also does not seem to crash the site any more. I have reactivated the cronjobs.
I think, the other issue was blocking the site-functions. When this happened during a WPDM Pro cron job, it seemed to break everything.
So when the site is overloaded, something that WPDM Pro does breaks the site completely. So I always had to deactivate the plugin. But the underlying issue was something else.
So everything is fine now.
Hi Tahasin,
time for an update. I checked your recommended setting define('DISABLE_WP_CRON', true);
This setting is already activated on our site. So cronjobs should not be triggered on access.
The wp-cron.php gets triggered by an external mechanism every 5 minutes.
I also have disabled the _wpdm_cron job completely (scheduled every 6 hours) and did not have any outages since then.
Can you tell me what this job does and if it’s crucial to WPDM to work.
Greetings
It seems to coincide with the _wpdm_cron Job.
It runs every six hours. Dont know why it didnt happen this morning,
but the error now seems about right that time.
What does it do?
### WordPress Environment ###
WordPress Version: 7.1
Site URL:
HTTPS: Yes
Multisite: No
WPDM Version: 7.5.6
### Server Environment ###
PHP Version: 8.3.33
MySQL Version: 10.11.18
Web Server: Apache
### PHP Configuration ###
Memory Limit: 256M
Max Execution Time: 180s (MAXIMUM I CAN SET)
Upload Max Filesize: 100M
Post Max Size: 100M
Max File Uploads: 20
Max Input Vars: 1000
### Required PHP Extensions ###
cURL: Installed
Zip: Installed
Mbstring: Installed
JSON: Installed
### Recommended PHP Extensions ###
GD Library: Installed
ImageMagick: Installed
OpenSSL: Installed
Fileinfo: Installed
### Directory Permissions ###
Uploads: Writable
WPDM Files: Writable
WPDM Cache: Writable
This is the debug.log after I re-enabled WPDM, so it worked, then I started the WPDM_CRON Job manually. Site didnt crash totally but became very very slow. Maybe at some job-runtimes, it crashes.
[16-Sep-2026 15:23:33 UTC] PHP Fatal error: Uncaught Error: Class “WPDM\__\__” not found in /usr/www/users/mbconnt/wordpress/wp-content/plugins/download-manager/src/wpdm-functions.php:1176
Stack trace:
#0 /usr/www/users/mbconnt/wordpress/wp-content/plugins/download-manager/src/AssetManager/AssetManager.php(136): wpdm_query_var()
#1 /usr/www/users/mbconnt/wordpress/wp-includes/class-wp-hook.php(353): WPDM\AssetManager\AssetManager->assetPicker()
#2 /usr/www/users/mbconnt/wordpress/wp-includes/class-wp-hook.php(377): WP_Hook->apply_filters()
#3 /usr/www/users/mbconnt/wordpress/wp-includes/plugin.php(523): WP_Hook->do_action()
#4 /usr/www/users/mbconnt/wordpress/wp-settings.php(779): do_action()
#5 /usr/www/users/mbconnt/wordpress/wp-config.php(111): require_once(‘/usr/www/users/…’)
#6 /usr/www/users/mbconnt/wordpress/wp-load.php(50): require_once(‘/usr/www/users/…’)
#7 /usr/www/users/mbconnt/wordpress/wp-blog-header.php(13): require_once(‘/usr/www/users/…’)
#8 /usr/www/users/mbconnt/wordpress/index.php(17): require(‘/usr/www/users/…’)
#9 {main}
thrown in /usr/www/users/mbconnt/wordpress/wp-content/plugins/download-manager/src/wpdm-functions.php on line 1176
[16-Sep-2026 15:23:33 UTC] PHP Fatal error: Uncaught Error: Class “WPDM\__\__” not found in /usr/www/users/mbconnt/wordpress/wp-content/plugins/download-manager/src/wpdm-functions.php:1176
Stack trace:
#0 /usr/www/users/mbconnt/wordpress/wp-content/plugins/download-manager/src/AssetManager/AssetManager.php(136): wpdm_query_var()
#1 /usr/www/users/mbconnt/wordpress/wp-includes/class-wp-hook.php(353): WPDM\AssetManager\AssetManager->assetPicker()
#2 /usr/www/users/mbconnt/wordpress/wp-includes/class-wp-hook.php(377): WP_Hook->apply_filters()
#3 /usr/www/users/mbconnt/wordpress/wp-includes/plugin.php(523): WP_Hook->do_action()
#4 /usr/www/users/mbconnt/wordpress/wp-settings.php(779): do_action()
#5 /usr/www/users/mbconnt/wordpress/wp-config.php(111): require_once(‘/usr/www/users/…’)
#6 /usr/www/users/mbconnt/wordpress/wp-load.php(50): require_once(‘/usr/www/users/…’)
#7 /usr/www/users/mbconnt/wordpress/wp-blog-header.php(13): require_once(‘/usr/www/users/…’)
#8 /usr/www/users/mbconnt/wordpress/index.php(17): require(‘/usr/www/users/…’)
#9 {main}
thrown in /usr/www/users/mbconnt/wordpress/wp-content/plugins/download-manager/src/wpdm-functions.php on line 1176
[16-Sep-2026 15:24:48 UTC] PHP Deprecated: Function mcrypt_get_iv_size() is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/plugins/all-in-one-wp-security-and-firewall/includes/simba-tfa/providers/totp/loader.php on line 938
[16-Sep-2026 15:24:48 UTC] PHP Deprecated: Function mcrypt_decrypt() is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/plugins/all-in-one-wp-security-and-firewall/includes/simba-tfa/providers/totp/loader.php on line 958
[16-Sep-2026 15:24:51 UTC] PHP Deprecated: Automatic conversion of false to array is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/plugins/divi-contact-form-helper/app/Controllers/PWH_DCFH_DB.php on line 460
[16-Sep-2026 15:25:02 UTC] Cron-Reschedule-Event-Fehler für Hook: __wpdm_process_jobs, Fehlercode: invalid_schedule, Fehlermeldung: Die Ereignisplanung existiert nicht., Daten: {“schedule”:”wpdm_every_5_minutes”,”args”:[],”interval”:300}
[16-Sep-2026 15:39:11 UTC] …/ImageHotspotChild/ImageHotspotChild.php:1160 DIPI_ImageHotspotChild::render():
You’re Doing It Wrong! DIPI_ImageHotspotChild::dipi_generate_ripple_effect_styles() doesn’t exist.
[16-Sep-2026 15:42:08 UTC] PHP Fatal error: Maximum execution time of 180 seconds exceeded in /usr/www/users/mbconnt/wordpress/wp-content/themes/Divi/core/components/data/Utils.php on line 977
[16-Sep-2026 15:50:31 UTC] PHP Deprecated: preg_match(): Passing null to parameter #2 ($subject) of type string is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/plugins/divi-contact-form-helper/app/Frontend/Request/PWH_DCFH_Post_Request.php on line 276
[16-Sep-2026 15:53:15 UTC] PHP Deprecated: file_exists(): Passing null to parameter #1 ($filename) of type string is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/themes/Divi/core/components/PageResource.php on line 571
[16-Sep-2026 15:53:15 UTC] PHP Deprecated: file_exists(): Passing null to parameter #1 ($filename) of type string is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/themes/Divi/core/components/PageResource.php on line 571
[16-Sep-2026 15:53:15 UTC] PHP Deprecated: file_exists(): Passing null to parameter #1 ($filename) of type string is deprecated in /usr/www/users/mbconnt/wordpress/wp-content/themes/Divi/core/components/PageResource.php on line 571
Set author’s post as private.
Submit Reply
WordPress Download Manager
The complete WordPress file download management solution. Trusted by 200,000+ websites worldwide for secure file hosting, digital product sales, and download analytics.
Products
Download Manager Pro
Premium Packages
Add-ons
Themes
Pricing
Resources
Documentation
Blog
Support
Changelog
WordPress.org
Company
About Us
Contact
Affiliate Program
Terms of Service
Privacy Policy
© 2026 W3 Eden, Inc. All rights reserved.
W3 Eden, Inc.
Outreach
CommFlow
Fintrail
I cant deactivate other Plugins as they are crucial to the website.
Can i deactivate the cronjob and run it manually once a day? Or maybe I move the scheduled time?
It always happend in the afternoon.
UPDATE: Broken again. About 10 minutes after the cron did run manually
No additional entries in debug.log
It just happened again. About 24 hours after last time.
Site is not responding. After a long period I get 503.
I have a activated a logfile, but there is no entry about an error with WDPM Pro.
I renamed the folder “download-manager” in plugins. So that WPDM Pro gets deactivated.
Site is responding instantly after this
I will enable logging and wait for the error to reappear.
Currently I am using
Wordpress 7.1
PHP 8.4 (even tried rollback to 8.3), Hosted at Hetzner
WPDM Pro Version 7.5.6 (I think this one is brand new)